[SIP Beyond VoIP] Getting Error: AttributeError: 'TLSSettings' object has no attribute 'protocol'

Tony DeSousa tony at telax.com
Wed Oct 16 17:12:22 CEST 2013


I just finished building the latest SIPSimpleClient SDK (python-sipsimple-1.0.0) and the sipclients-1.0.0 on Debian 7.3.
The process went on like a charm.

I was able to use the clients to register accounts but when I tried to subscribe to presence of a UA registered to my Freeswitch on another box I get the following error.

root at mars:/usr/bin# sip-subscribe-presence -a 1000 at freeswitchIPAddress
using set_wakeup_fd
Using account 1000 at
Traceback (most recent call last):
  File "/usr/bin/sip-subscribe-presence", line 617, in <module>
    return_code = application.run()
  File "/usr/bin/sip-subscribe-presence", line 168, in run
AttributeError: 'TLSSettings' object has no attribute 'protocol'

I looked through the available documentation and Googled it but still was not able to find a fix or a understanding of this issue. I tried to find a way to change the sip.transport_list to exclude tls but even that I couldn't figure it out. Any ideas?

I assume the sip-client scripts are a reference/example implementation to showcase SIPSimpleClient SDK and that they need to be expanded by proficient programmers to each situation, correct?

Thanks in advance for any help.
Tony de Sousa

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20131016/a5ea89df/attachment.html>

More information about the SIPBeyondVoIP mailing list