[SIP Beyond VoIP] failed to install blink 0.6.0 on wheezy

Saúl Ibarra Corretgé saul at ag-projects.com
Fri Dec 20 13:34:53 CET 2013


On Dec 19, 2013, at 8:14 PM, Juha Heinanen wrote:

> i tried to install the newly announced blink on debian wheezy, but it
> failed like this:
> 
> Setting up blink (0.6.0wheezy) ...
> SyntaxError: ('invalid syntax', ('/usr/lib/python2.6/dist-packages/blink/chat.py', 277, 134, "        self.audio_icon.setVisible(session.blink_session.streams.types.intersection(('audio', 'video', 'screen-sharing')) == {'audio'})\n"))
> 
> SyntaxError: ('invalid syntax', ('/usr/lib/python2.6/dist-packages/blink/sessions.py', 121, 51, '        self._stream_map = {stream.type: stream for stream in streams}\n'))
> 
> dpkg: error processing blink (--configure):
> subprocess installed post-installation script returned error exit status 101
> 

Python 2.6 is no longer supported. If the package for Wheezy was built for 2.6 then it's a bug, it should only have been built for Python 2.7.

Thanks for the report Juha!

--
Saúl Ibarra Corretgé
AG Projects





More information about the SIPBeyondVoIP mailing list