[Blink] Problems with python

Juan Luis Ordóñez Lucas jlol84 at gmail.com
Fri May 13 22:45:25 CEST 2011


Hello,

2011/5/13 <blink-request at lists.ag-projects.com>


> Hi,
>
> On 05/12/2011 11:49 PM, Juan Luis Ord??ez Lucas wrote:
> > Hello, I'm trying to use Blink on ArchLinux and I'm getting a few
> > problems. First, ArchLinux uses Python3 by default so I had to change
> > that on /bin/blink
> > Second, python-application is an old version in ArchLinux, so I
> > downloaded and installed it.
> > Now, after installing python-gnutls I get the next error:
> >          AttributeError: /usr/lib/libgnutls.so.26: undefined symbol:
> > gnutls_openpgp_privkey_sign_hash
> >
> > I want to give a try to this software, can you help me with this
> > problem? There's any magic tutorial that I missed? (I was searching for
> > a while..)
> >
>
> IIRC ArchLinux does have a Python 2.x version, but its 2.7, which we
> currently not support, but we will. If you manage to get Python 2.6 on
> your machine, you can proceed with the libraries.
>
> The error you pasted comes from python-gnutls, what version of libgnutls
> and python-gnutls are you running?
>
> --
> Sa?l Ibarra Corretg?
> AG Projects
>
>
My versions are python-gnutls 1.2.0 and libgnutls 2.12.4.
About Python 2.6 it's beeing difficult to use it, I cannot replace 2.7 and I
don't know how to have them installed at the same time. I tried to download
compile and execute in a folder at my home directory but after that I had
problems with the required libraries that I was also downloading and
compiling. So I think I give up for now, maybe I will try with a Virtual
machine on another GNU/Linux flavour.
Anyway would be interesting to know if you plan to support newer versions of
Python.

Best regards and thanks
-- 
Juan Luis Ordóñez
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/blink/attachments/20110513/a0318eec/attachment.html>


More information about the Blink mailing list