<html><head><meta http-equiv="Content-Type" content="text/html charset=iso-8859-1"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><br><div><div>On Sep 27, 2013, at 4:32 PM, David Hubbard <<a href="mailto:david.hubbard@agenor.co.uk">david.hubbard@agenor.co.uk</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">
  
    <meta content="text/html; charset=ISO-8859-1" http-equiv="Content-Type">
  
  <div text="#000000" bgcolor="#FFFFFF">
    Saúl<br>
    <br>
    That's better<br>
    <br>
    I then got a <br>
    <br>
    <blockquote>  File
      "/usr/sylkserver/sylk/applications/xmppgateway/im.py", line 24, in
      <module><br>
          from sylk.applications.xmppgateway.xmpp import XMPPManager<br>
        File
      "/usr/sylkserver/sylk/applications/xmppgateway/xmpp/__init__.py",
      line 8, in <module><br>
          from wokkel.disco import DiscoClientProtocol<br>
      ImportError: No module named wokkel.disco<br>
    </blockquote>
    <br>
    So also installed "wokkel-0.7.1" package and...<br>
    <br>
    Hey presto - sylkserver now runs without showing an error - with
    XMPP listener on 5269<br>
    <br>
    Now I just need to figure out how to configure all this - I may post
    another thread ;o)<br></div></blockquote><div><br></div><div>Well, there is nothing that must be configured beyond the domain name. All defaults should just work.</div><div><br></div><div><br></div><blockquote type="cite"><div text="#000000" bgcolor="#FFFFFF">Thank you very much<br>
    <br>
    David<br>
    <br>
    <br>
    <br>
    <div class="moz-cite-prefix">On 27/09/2013 14:58, Saúl Ibarra
      Corretgé wrote:<br>
    </div>
    <blockquote cite="mid:BF356A2D-3CFF-4425-9C0A-B2776CC46327@ag-projects.com" type="cite">
      <pre wrap="">On Sep 27, 2013, at 2:39 PM, David Hubbard wrote:

</pre>
      <blockquote type="cite">
        <pre wrap="">Adrian

So I have pulled down latest (I think) via  "darcs get <a class="moz-txt-link-freetext" href="http://devel.ag-projects.com/repositories/python-sipsimple">http://devel.ag-projects.com/repositories/python-sipsimple</a>" and "darcs pull -a"   <for others ref: <a class="moz-txt-link-freetext" href="http://sipsimpleclient.org/projects/sipsimpleclient/wiki/SipInstallation">http://sipsimpleclient.org/projects/sipsimpleclient/wiki/SipInstallation</a>>

Now when building sipsimple  using "python -v setup.py build" I get:

Configuring PJSIP
# /usr/local/lib/python2.7/encodings/string_escape.pyc matches /usr/local/lib/python2.7/encodings/string_escape.py
import encodings.string_escape # precompiled from /usr/local/lib/python2.7/encodings/string_escape.pyc
error: Permission denied
<Head scratch>

</pre>
      </blockquote>
      <pre wrap="">Does deps/pjsip/aconfigure have the executable bit set? Do the checkout like this:

darcs get --set-scripts-executable <a class="moz-txt-link-freetext" href="http://devel.ag-projects.com/repositories/python-sipsimple">http://devel.ag-projects.com/repositories/python-sipsimple</a>


Regards,

--
Saúl Ibarra Corretgé
AG Projects



</pre>
    </blockquote>
    <br>
  </div>

</blockquote></div><br></body></html>