<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Both Ejabberd and SylkServer work out of the box without any need for special configurations. Kamailio however is a programable SIP server environment, just downloading it is not enough to run a service, it must be properly configured which is not a trivial task.<div><br></div><div>You should consult Kamailio mailing list for debugging your setup.</div><div><br></div><div>Adrian</div><div><br><div><br></div><div><br><div><div>On Mar 29, 2013, at 7:40 PM, Martin Krıka wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">Alright, I didn't know that jitsi doesn't support MSRP messaging. So I went to xmppgateway.ini and disabled use of MSRP for chat. IM now works in both directions. But I still don't know why the clients can't see each other presence. I added SIP and XMPP PI logs from SylkServer as you told me to. Now I'm not sure if the problem isn't in my Kamailio or Ejabberd. They are only basic installation through repositories.<div>
<br></div><div>Martin<br><br><div class="gmail_quote">2013/3/28 Adrian Georgescu <span dir="ltr"><<a href="mailto:ag@ag-projects.com" target="_blank">ag@ag-projects.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div style="word-wrap:break-word">Pl enable and paste SylkServer logs.<div><br></div><div>Adrian</div><div><br><div><div><div class="h5"><div>On Mar 27, 2013, at 4:42 PM, Martin Krıka wrote:</div><br></div></div><blockquote type="cite">
<div><div class="h5">Hi everyone,<div><br></div><div>I am trying to run sylkserver 2.4 as SIP/XMPP gateway in Virtualbox. My topology is like this:</div><div><br></div><div>[sip client] <=> [sip server] <=> [sylkserver] <=> [xmpp server] <=> [xmpp client]</div>

<div><br></div><div>As sip server I use Kamailio 3.3.4, for xmpp I use ejabberd 2.1.10 and as sip/xmpp client I use jitsi.</div><div>I have sip domain named <a href="http://sip.example.com/" target="_blank">sip.example.com</a> and xmpp domain named <a href="http://xmpp.example.com/" target="_blank">xmpp.example.com</a></div>

<div><br></div><div>In sylkserver config.ini I changed default_application to xmppgateway and outbound_proxy to the name of my sip server.</div><div>In xmppgateway.ini I added to domains <a href="http://sip.example.com/" target="_blank">sip.example.com</a>. Sylkserver is running and listening on all ports needed.</div>

<div>In DNS I added SRV record _xmpp-server._<a href="http://tcp.sip.example.com/" target="_blank">tcp.sip.example.com</a> pointing to my sylkserver and sip SRV records for <a href="http://xmpp.example.com/" target="_blank">xmpp.example.com</a> also pointing to sylkserver.</div>

<div><br></div><div>When I run this configuration and try to communicate between sip and xmpp client, they behave really strange. They see each other offline no matter what.</div><div>Messages from sip client to xmpp client are received succesfully but when I try to send message from xmpp client to sip, instead of a message, sip client will</div>

<div>receive a call from xmpp, which will  cancel if picked.up.</div><div><br></div><div>Could someone please tell me if I got the configuration wrong or there's a different problem ?</div><div><br></div><div>Regards</div>

<div>Martin</div></div></div>
_______________________________________________<br>SIPBeyondVoIP mailing list<br><a href="mailto:SIPBeyondVoIP@lists.ag-projects.com" target="_blank">SIPBeyondVoIP@lists.ag-projects.com</a><br><a href="http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip" target="_blank">http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip</a><br>
</blockquote></div><br></div></div></blockquote></div><br></div>
<span><sip_trace.txt></span><span><xmpp_trace.txt></span></blockquote></div><br></div></div></body></html>