[SIP Beyond VoIP] Msrp relay and opensips, tls encryption certificate issues [2]

martin-n martin-n martin-n at rambler.ru
Sun Feb 8 22:13:14 CET 2015

I also tried to generate the certificates with

./gen_relay_creds_self.sh xx.xx.xx.xx

To try and workout without the client cert. But i got the same error in msrprelay

gc: collectable <list 0x7ffba7243998>
gc: collectable <list 0x7ffba72438c0>
gc: collectable <list 0x7ffba7243ea8>
gc: collectable <tuple 0x7ffba7437ed0>
gc: collectable <StgDict 0x7ffba7379a40>
gc: collectable <_ctypes.PyCArrayType 0x1527e80>
gc: collectable <getset_descriptor 0x7ffba71f7878>
gc: collectable <getset_descriptor 0x7ffba71f78c0>
gc: collectable <tuple 0x7ffbab9e4c00>
gc: collectable <getset_descriptor 0x7ffba71f7908>
gc: collectable <getset_descriptor 0x7ffba71f7950>
debug: (my ip)xx.xx.xx.xx:49610 (NEW): Connection lost: peer rejected our
certificate as invalid

And in the blink log:

2015-02-08 23:07:01.970811 [blink.exe 1356]: Connecting to MSRPRelay
msrps://xx.xx.xx.xx (my server ip)
2015-02-08 23:07:02.798938 [blink.exe 1356]: Could not connect to relay MSRPRelay

(logging level is 5)

But! If i do not use the tls in opensips, the msrp works just fine. So i assume
this is a problem with mixing the certificates.

I have the local certificate authority in one file set in blink - calist.pem
which contains the CA from opensips and CA from msrprelay.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20150209/3cca899d/attachment.html>

More information about the SIPBeyondVoIP mailing list