[SIP Beyond VoIP] Unable to start sylkserver error: No module named video

Saúl Ibarra Corretgé saul at ag-projects.com
Wed Apr 29 10:30:57 CEST 2015


Ubuntu 12.04 is no longer supported as it lacks recent enough versions of gnutls and ffmpeg.

Supported Ubuntu versions are Trusty, Utopic and (soon) Vivid.


Cheers,

On 24 Apr 2015, at 05:59, Kripa Shanker Ram Tripathi <kripa.tripathi at aricent.com> wrote:

> Any idea on below mentioned libgnutls issue?
>  
> -Kripa
>  
> From: Kripa Shanker Ram Tripathi 
> Sent: Thursday, April 23, 2015 2:28 PM
> To: SIP Beyond VoIP
> Subject: RE: [SIP Beyond VoIP] Unable to start sylkserver error: No module named video
>  
> Thanks Adrian,
>  
> We are able to proceed but again stuck at with error “AttributeError: /usr/lib/x86_64-linux-gnu/libgnutls.so.28: undefined symbol: gnutls_certificate_verify_peers3”
>  
> Actually we updated sipsimple and then try to start sylkserver but that time we observed error for libgnutls and it was saying libgnutls is not found at your system so installed libgnutls28.
>  
> Apr 23 11:01:36 gitserver sylk-server[7682]:     from gnutls.validators import method_args, one_of
> Apr 23 11:01:36 gitserver sylk-server[7682]:   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/validators.py", line 9, in <module>
> Apr 23 11:01:36 gitserver sylk-server[7682]:     from gnutls.constants import *
> Apr 23 11:01:36 gitserver sylk-server[7682]:   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/constants.py", line 38, in <module>
> Apr 23 11:01:36 gitserver sylk-server[7682]:     from gnutls.library import constants
> Apr 23 11:01:36 gitserver sylk-server[7682]:   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/library/__init__.py", line 59, in <module>
> Apr 23 11:01:36 gitserver sylk-server[7682]:     libgnutls = load_library(version=28)
> Apr 23 11:01:36 gitserver sylk-server[7682]:   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/library/__init__.py", line 56, in load_library
> Apr 23 11:01:36 gitserver sylk-server[7682]:     raise RuntimeError('cannot find libgnutls on this system')
> Apr 23 11:01:36 gitserver sylk-server[7682]: RuntimeError: cannot find libgnutls on this system
>  
>  
> After this libgnutls28 installation as said we have below errors.
>  
> Below is error log.
>  
> Error logs-
>  
>  
> root at gitserver:/home/lk/sylkserver# ./sylk-server --no-fork
> Starting SylkServer 2.9.0, config=/etc/sylkserver/config.ini
> Using SIP SIMPLE SDK version 1.4.2
> fatal error: failed to create SylkServer: /usr/lib/x86_64-linux-gnu/libgnutls.so.28: undefined symbol: gnutls_certificate_verify_peers3
> Traceback (most recent call last):
>   File "./sylk-server", line 70, in main
>     from sylk.server import SylkServer
>   File "/home/lk/sylkserver/sylk/server.py", line 15, in <module>
>     from sipsimple.account import Account, BonjourAccount, AccountManager
>   File "/usr/lib/python2.7/dist-packages/sipsimple/account/__init__.py", line 21, in <module>
>     from gnutls.crypto import X509Certificate, X509PrivateKey
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/crypto.py", line 11, in <module>
>     from gnutls.validators import method_args, one_of
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/validators.py", line 9, in <module>
>     from gnutls.constants import *
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/constants.py", line 38, in <module>
>     from gnutls.library import constants
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/library/__init__.py", line 64, in <module>
>     from gnutls.library import errors
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/library/errors.py", line 15, in <module>
>     from gnutls.library.functions import gnutls_strerror, gnutls_alert_get
>   File "/usr/local/lib/python2.7/dist-packages/python_gnutls-2.0.1-py2.7.egg/gnutls/library/functions.py", line 220, in <module>
>     gnutls_certificate_verify_peers3 = libgnutls.gnutls_certificate_verify_peers3
>   File "/usr/lib/python2.7/ctypes/__init__.py", line 378, in __getattr__
>     func = self.__getitem__(name)
>   File "/usr/lib/python2.7/ctypes/__init__.py", line 383, in __getitem__
>     func = self._FuncPtr((name_or_ordinal, self))
> AttributeError: /usr/lib/x86_64-linux-gnu/libgnutls.so.28: undefined symbol: gnutls_certificate_verify_peers3
>  
>  
>  
> Regards,
> Kripa
>  
> From: sipbeyondvoip-bounces at lists.ag-projects.com [mailto:sipbeyondvoip-bounces at lists.ag-projects.com] On Behalf Of ag at ag-projects.com
> Sent: Wednesday, April 22, 2015 7:03 PM
> To: SIP Beyond VoIP
> Subject: Re: [SIP Beyond VoIP] Unable to start sylkserver error: No module named video
>  
> You must upgrade python-sipsimple package.
>  
> Adrian
>  
> On 22 Apr 2015, at 10:15, Kripa Shanker Ram Tripathi <kripa.tripathi at aricent.com> wrote:
>  
> 
> Hi All,
>  
> I need some assistance in installing sylkserver.
>  
> Actually we install the sylkserver with apt-get and also source code on our Ubuntu 12.04 machine but when we start the service we observed below error and unable to proceed further.
>  
> Apr 21 13:02:18 gitserver sylk-server[24627]: Starting SylkServer 2.9.0, config=/etc/sylkserver/config.ini
> Apr 21 13:02:18 gitserver sylk-server[24627]: Using SIP SIMPLE SDK version 1.4.2
> Apr 21 13:02:19 gitserver sylk-server[24627]: using set_wakeup_fd
> Apr 21 13:02:19 gitserver sylk-server[24627]: fatal error: failed to create SylkServer: No module named video
> Apr 21 13:02:19 gitserver sylk-server[24627]: Traceback (most recent call last):
> 
> 
> Apr 21 13:02:19 gitserver sylk-server[24627]: File "/usr/bin/sylk-server", line 70, in main
> Apr 21 13:02:19 gitserver sylk-server[24627]: from sylk.server import SylkServer
> Apr 21 13:02:19 gitserver sylk-server[24627]: File "/usr/local/lib/python2.7/dist-packages/sylk/server.py", line 24, in <module>
> Apr 21 13:02:19 gitserver sylk-server[24627]: from sipsimple.video import VideoDevice
> Apr 21 13:02:19 gitserver sylk-server[24627]: ImportError: No module named video
> 
> 
>  
> Thanks in advance.
>  
>  
> Regards,
>  
> Kripa Shanker Ram Tripathi
>  
> kripa.tripathi at aricent.com | O: +91.124.409.5888 x 7511 | M: +91.999.948.7514
> <image001.jpg>
>  
>  
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus." _______________________________________________
> SIPBeyondVoIP mailing list
> SIPBeyondVoIP at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip
>  
> --
> Adrian
> 
>  
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus." _______________________________________________
> SIPBeyondVoIP mailing list
> SIPBeyondVoIP at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip

--
Saúl Ibarra Corretgé
AG Projects



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 842 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20150429/b82c74fe/attachment.pgp>


More information about the SIPBeyondVoIP mailing list