[SIP Beyond VoIP] Source Compile / Install

David Hubbard david.hubbard at agenor.co.uk
Fri Sep 27 16:32:23 CEST 2013


Saúl

That's better

I then got a

       File "/usr/sylkserver/sylk/applications/xmppgateway/im.py", line
    24, in <module>
         from sylk.applications.xmppgateway.xmpp import XMPPManager
       File
    "/usr/sylkserver/sylk/applications/xmppgateway/xmpp/__init__.py",
    line 8, in <module>
         from wokkel.disco import DiscoClientProtocol
    ImportError: No module named wokkel.disco


So also installed "wokkel-0.7.1" package and...

Hey presto - sylkserver now runs without showing an error - with XMPP 
listener on 5269

Now I just need to figure out how to configure all this - I may post 
another thread ;o)

Thank you very much

David



On 27/09/2013 14:58, Saúl Ibarra Corretgé wrote:
> On Sep 27, 2013, at 2:39 PM, David Hubbard wrote:
>
>> Adrian
>>
>> So I have pulled down latest (I think) via  "darcs get http://devel.ag-projects.com/repositories/python-sipsimple" and "darcs pull -a"   <for others ref: http://sipsimpleclient.org/projects/sipsimpleclient/wiki/SipInstallation>
>>
>> Now when building sipsimple  using "python -v setup.py build" I get:
>>
>> Configuring PJSIP
>> # /usr/local/lib/python2.7/encodings/string_escape.pyc matches /usr/local/lib/python2.7/encodings/string_escape.py
>> import encodings.string_escape # precompiled from /usr/local/lib/python2.7/encodings/string_escape.pyc
>> error: Permission denied
>> <Head scratch>
>>
> Does deps/pjsip/aconfigure have the executable bit set? Do the checkout like this:
>
> darcs get --set-scripts-executable http://devel.ag-projects.com/repositories/python-sipsimple
>
>
> Regards,
>
> --
> Saúl Ibarra Corretgé
> AG Projects
>
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20130927/ceb7d2c3/attachment-0001.html>


More information about the SIPBeyondVoIP mailing list