[SIP Beyond VoIP] opus codec not available

Saúl Ibarra Corretgé saul at ag-projects.com
Sun Jul 14 13:28:54 CEST 2013


On Jul 14, 2013, at 12:56 PM, Juha Heinanen wrote:

> i build latest python-sipsimple_0.35.0 debian package and for some
> reason it does not include support for opus codec.  i get error when i
> include opus in codec list:
> 
> $ sip-settings --general set rtp.audio_codec_list=opus,speex,PCMU,PCMA
> using set_wakeup_fd
> rtp.audio_codec_list: illegal codec values: opus, speex, PCMU, PCMA
> SIP SIMPLE general settings updated
> 
> the error disappears if i omit opus from the list.
> 
> do i need to something special in order to include opus in
> python-sipsimple debian package?  i do have libopus-dev installed.
> 

Are you compiling from latest darcs trunk? You don't need liboups-dev, as it's bundled inside sipsimple.

--
Saúl Ibarra Corretgé
AG Projects





More information about the SIPBeyondVoIP mailing list