[SIP Beyond VoIP] Sylk-Server does not run on Ubuntu 11.04 natty due to type error

Adrian Georgescu ag at ag-projects.com
Fri Oct 5 15:13:55 CEST 2012


What did you put in your config.ini?

Adrian

On Oct 5, 2012, at 3:11 PM, Anil KARADAG wrote:

> Hi all,
>  
>  
> I have an issue, I don’t run sylk-server on ubuntu 11.04. I installed it successful.
>  
>  
> root at trhtlangley35:~# sylk-server --no-fork
> Starting SylkServer 2.1.0, config=/etc/sylkserver/config.ini
> fatal error: failed to create SylkServer: expected string or Unicode object, NoneType found
> Traceback (most recent call last):
>   File "/usr/bin/sylk-server", line 68, in main
>     from sylk.server import SylkServer
>   File "/usr/lib/python2.7/dist-packages/sylk/server.py", line 13, in <module>
>     from sipsimple.account import Account, BonjourAccount, AccountManager
>   File "/usr/local/lib/python2.7/dist-packages/sipsimple/account/__init__.py", line 22, in <module>
>     from gnutls.interfaces.twisted import X509Credentials
>   File "/usr/lib/python2.7/dist-packages/gnutls/interfaces/twisted/__init__.py", line 10, in <module>
>     from twisted.python import failure
>   File "/usr/lib/python2.7/dist-packages/application/log/extensions/twisted/twisted.py", line 14, in <module>
>     import twisted
> TypeError: expected string or Unicode object, NoneType found
> root at trhtlangley35:~#
>  
>  
> I checked line 68:
>  
> from sylk.server import SylkServer
>  
>  
> I import it after sys there is no any issues. I think there is a bug. Please can you help me if you know fix of it.
>  
>  
> root at trhtlangley35:~# python
> Python 2.7.1+ (r271:86832, Sep 27 2012, 21:12:17)
> [GCC 4.5.2] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> >>> from sylk.server import SylkServer
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/usr/lib/python2.7/dist-packages/sylk/server.py", line 13, in <module>
>     from sipsimple.account import Account, BonjourAccount, AccountManager
>   File "/usr/local/lib/python2.7/dist-packages/sipsimple/account/__init__.py", line 22, in <module>
>     from gnutls.interfaces.twisted import X509Credentials
>   File "/usr/lib/python2.7/dist-packages/gnutls/interfaces/twisted/__init__.py", line 10, in <module>
>     from twisted.python import failure
>   File "/usr/lib/python2.7/dist-packages/application/log/extensions/twisted/twisted.py", line 14, in <module>
>     import twisted
> TypeError: expected string or Unicode object, NoneType found
> >>> import sys
> >>> from sylk.server import SylkServer
> >>>
> >>> import os
> >>> os.system("/usr/bin/sylk-server --no-fork");
> Starting SylkServer 2.1.0, config=/etc/sylkserver/config.ini
> fatal error: failed to create SylkServer: expected string or Unicode object, NoneType found
> Traceback (most recent call last):
>   File "/usr/bin/sylk-server", line 68, in main
>     from sylk.server import SylkServer
>   File "/usr/lib/python2.7/dist-packages/sylk/server.py", line 13, in <module>
>     from sipsimple.account import Account, BonjourAccount, AccountManager
>   File "/usr/local/lib/python2.7/dist-packages/sipsimple/account/__init__.py", line 22, in <module>
>     from gnutls.interfaces.twisted import X509Credentials
>   File "/usr/lib/python2.7/dist-packages/gnutls/interfaces/twisted/__init__.py", line 10, in <module>
>     from twisted.python import failure
>   File "/usr/lib/python2.7/dist-packages/application/log/extensions/twisted/twisted.py", line 14, in <module>
>     import twisted
> TypeError: expected string or Unicode object, NoneType found
> 256
> >>> 
>  
> >>> print sys.path
> ['', '/usr/local/lib/python2.7/dist-packages/wokkel-0.7.0-py2.7.egg', '/usr/local/lib/python2.7/dist-packages/python_dateutil-2.1-py2.7.egg', '/usr/local/lib/python2.7/dist-packages/Twisted-12.2.0-py2.7-linux-x86_64.egg', '/usr/local/lib/python2.7/dist-packages/six-1.2.0-py2.7.egg', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-linux2', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PIL', '/usr/lib/pymodules/python2.7/gtk-2.0', '/usr/lib/python2.7/dist-packages/gst-0.10', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/pymodules/python2.7/ubuntuone-storage-protocol', '/usr/lib/pymodules/python2.7/ubuntuone-control-panel', '/usr/lib/pymodules/python2.7/ubuntuone-client']
> >>> 
>  
>  
>  
> Thanks for your help
>  
>  
> Anil KARADAG
> Senior Design Engineer in R&D
> http://en.netas.com.tr/default.aspx
>  
>  
> _______________________________________________
> SIPBeyondVoIP mailing list
> SIPBeyondVoIP at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20121005/cc9f5de2/attachment-0001.html>


More information about the SIPBeyondVoIP mailing list