[SIP Beyond VoIP] Unknown thread assertion using test sipclient

Saúl Ibarra Corretgé saul at ag-projects.com
Tue Nov 15 10:23:17 CET 2011


On Nov 14, 2011, at 9:14 PM, Rory Latchem wrote:

> I get this assertion every time I call sip-register, sip-session, sip-audio-session or sip-message (only the sip-settings command works for me).
> 

If you didn't install the ALSA library headers the core will be compiled without ALSA, and most likely you'll not see any devices, in case it didn't crash :-S

> Sorry, I'm new to this so I haven't studied the ALSA headers yet. I've just installed the SDK and wanted to see if I could access our test SIP server with the test client tools.
> 
> I saw a comment in a previous posting that python 2.5 wasn't supported anymore, but I'm not sure if that was correct or only in the context of a different OS.
> 

As of now we are no longer supporting Python 2.5. It may work or it may not, but it's not supported. Debian even removed it from Testing onwards.

Audio + Linux have proven to be not very good friends :-S any chance you can try a more recent Fedora? I tried 15 and worked fine.

I'm sorry I can't give you a better answer, but the devices / distributions I tested so far didn't present this problem, which seems to be somehow system dependent.


Regards,

--
Saúl Ibarra Corretgé
AG Projects





More information about the SIPBeyondVoIP mailing list