[SIP SIMPLE client] Problems getting SIP Simple SDK to work

J.M. Maurer uwog at uwog.net
Wed Nov 3 00:38:56 CET 2010


On Sat, 2010-10-23 at 14:49 -0400, Adrian Georgescu wrote:
> The package contains custom patches required for the software to work which not available in the official eventlet and the package has a different name, see the debian packaging files for example.

Ah, I was confused by fedora, since they already named the eventlet
package "python-eventlet". But 'your' python-eventlet != fedora's
python-eventlet :)

What about dragging stuff in over SVN during the build? That is
generally considered "bad practice".

Thanks!
  Marc


> So the answer is no.
>  
> Adrian
> 
> 
> On Oct 23, 2010, at 10:25 AM, J.M. Maurer wrote:
> 
> > Thanks! I'll try that.
> > 
> > That said, is there any plan to remove that exact dependency? Distro's
> > like Fedora will not allow any package to be added that ships his own
> > dependencies. And I also saw that when building msrp (or was it another
> > lib?) it dragged in external stuff. Distro's also disallow that.
> > 
> > Cheers!
> >  Marc
> > 
> > 
> > 
> > On Sat, 2010-10-23 at 09:46 -0400, Adrian Georgescu wrote:
> >> You must use only the python-eventlet version from our repository.
> >> 
> >> 
> >> darcs get http://devel.ag-projects.com/repositories/python-eventlet
> >> 
> >> 
> >> Adrian
> >> 
> >> On Oct 23, 2010, at 9:31 AM, J.M. Maurer wrote:
> >> 
> >>> Hi guys,
> >>> 
> >>> I'm having some trouble getting the SIP Simple SDK to work on a
> >>> Fedora
> >>> 13 machine, and I was hoping someone could help me out. I've
> >>> attached a
> >>> stacktrace to this mail from when I tried to run the sip-settings
> >>> command line tool.
> >>> 
> >>> I've installed following packages/versions:
> >>> 
> >>> python-imaging-1.1.6-17.fc12.x86_64
> >>> python-eventlet-0.9.12-1.fc13.noarch
> >>> python-msrplib-0.12.0-1.fc13.x86_64
> >>> python-dns-1.8.0-3.fc13.noarch
> >>> python-twisted-8.2.0-3.fc12.noarch
> >>> sipclients-0.15.0-1.fc13.x86_64
> >>> python-xcaplib-1.0.15-1.fc13.x86_64
> >>> python-lxml-2.2.7-1.fc13.x86_64
> >>> python-cjson-1.0.5-5.fc13.x86_64
> >>> python-sipsimple-0.16.1-1.fc13.x86_64
> >>> python-application-1.2.5-1.fc13.noarch
> >>> python-greenlet-0.4-1.fc13.x86_64
> >>> python-zope-interface-3.6.1-5.fc13.x86_64
> >>> python-gnutls-1.1.9-1.fc12.x86_64
> >>> 
> >>> From this list, I packaged python-application, python-greenlet,
> >>> python-msrplib, python-xcaplib, python-sipsimple and sipclients
> >>> myself.
> >>> The rest came from a stock Fedora 13 install.
> >>> 
> >>> I only see 1 potential problem with the versions in this list:
> >>> http://sipsimpleclient.com/browser/docs/Install.linux claims I need
> >>> python-eventlet = 0.8.11, where Fedora 13 ships with version 0.9.12
> >>> by
> >>> default.
> >>> 
> >>> Help would be very much appreciated,
> >>> 
> >>> Marc
> >>> 
> >>> <sipsimple-stacktrace.txt>_______________________________________________
> >>> SIPclient mailing list
> >>> SIPclient at lists.ag-projects.com
> >>> http://lists.ag-projects.com/mailman/listinfo/sipclient
> >>> 
> >> 
> >> 
> > 
> > 
> 





More information about the SIPBeyondVoIP mailing list