[Blink] version 3.0.2 fails to initialize returning IO error

Dan Pascu dan at ag-projects.com
Mon Feb 27 13:02:36 CET 2017


Can you list the content of the installed package on your system?

On 24 Feb 2017, at 21:26, Mircea Sava wrote:

> On Gentoo, I get the following when trying to run blink:
> 
>   Traceback (most recent call last):
>     File "/usr/lib/python-exec/python2.7/blink", line 67, in <module>
>       from blink import Blink
>     File "/usr/lib64/python2.7/site-packages/blink/__init__.py", line 31, in <module>
>       from blink.chatwindow import ChatWindow
>     File "/usr/lib64/python2.7/site-packages/blink/chatwindow.py", line 39, in <module>
>       from blink.contacts import URIUtils
>     File "/usr/lib64/python2.7/site-packages/blink/contacts.py", line 48, in <module>
>       from blink.sessions import SessionManager, StreamDescription
>     File "/usr/lib64/python2.7/site-packages/blink/sessions.py", line 48, in <module>
>       from blink.screensharing import ScreensharingWindow, VNCClient, ServerDefault
>     File "/usr/lib64/python2.7/site-packages/blink/screensharing/__init__.py", line 3, in <module>
>       from blink.screensharing.vncviewer import ScreensharingWindow, VNCViewer
>     File "/usr/lib64/python2.7/site-packages/blink/screensharing/vncviewer.py", line 387, in <module>
>       ui_class, base_class = uic.loadUiType(Resources.get('screensharing_dialog.ui'))
>     File "/usr/lib64/python2.7/site-packages/PyQt5/uic/__init__.py", line 194, in loadUiType
>       winfo = compiler.UICompiler().compileUi(uifile, code_string, from_imports, resource_suffix)
>     File "/usr/lib64/python2.7/site-packages/PyQt5/uic/Compiler/compiler.py", line 111, in compileUi
>       w = self.parse(input_stream, resource_suffix)
>     File "/usr/lib64/python2.7/site-packages/PyQt5/uic/uiparser.py", line 972, in parse
>       document = parse(filename)
>     File "/usr/lib64/python2.7/xml/etree/ElementTree.py", line 1182, in parse
>       tree.parse(source, parser)
>     File "/usr/lib64/python2.7/xml/etree/ElementTree.py", line 647, in parse
>       source = open(source, "rb")
>   IOError: [Errno 2] No such file or directory: u'/usr/lib64/python-exec/python2.7/share/blink/screensharing_dialog.ui'
> 
> These are the dependencies installed so far (I'm guessing I'm missing some of them): python-sipsimple-3.1.0, python-cjson-1.1.0, python-eventlib-0.2.1, python-msrplib-0.18.0, python-gnutls-2.0.1, python-xcaplib-1.1.0, python-application-2.1.0, and python-otr-1.2.0.
> 
> I'm in need of some guidance.
> _______________________________________________
> Blink mailing list
> Blink at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/blink
> 


--
Dan






More information about the Blink mailing list