[Blink] Blink doesn't work

Mike Nagie promike1987 at gmail.com
Wed Jan 27 13:36:19 CET 2016


Hello

You were right, after upgrading python-application, the program started 
working. It seems it works fine, only ekiga account doesn't work, but I 
might have not configured it right. Or maybe ekiga account is not 
supported at all.

Thank you for your help once again

Mike


On 16-01-24 19:07:27, Saúl Ibarra Corretgé wrote:
> Hi Mike!
> 
> > On 24 Jan 2016, at 00:48, Mike Nagie <promike1987 at gmail.com> wrote:
> > 
> > Hello!
> > 
> > I'd like to try this program, and even though it was hard to satisfy all
> > the dependencies under Archlinux, it doesn't work.
> > 
> > Traceback (most recent call last):
> >  File "/usr/bin/blink", line 30, in <module>
> >    from blink import Blink
> >  File "/usr/lib/python2.7/site-packages/blink/__init__.py", line 47, in
> > <module>
> >    from blink.chatwindow import ChatWindow
> >  File "/usr/lib/python2.7/site-packages/blink/chatwindow.py", line 40,
> > in <module>
> >    from blink.contacts import URIUtils
> >  File "/usr/lib/python2.7/site-packages/blink/contacts.py", line 47, in
> > <module>
> >    from blink.sessions import SessionManager, StreamDescription
> >  File "/usr/lib/python2.7/site-packages/blink/sessions.py", line 29, in
> > <module>
> >    from application.python.weakref import weakobjectmap,
> > defaultweakobjectmap
> > ImportError: cannot import name defaultweakobjectmap
> > 
> 
> How did you install Blink? From source? If you are running latest Blink source you’ll need python-application >= 2.0, that should do.
> 
> > 
> > [I also tried it on (x)Ubuntu:
> > 
> > Traceback (most recent call last):
> >  File "/usr/local/bin/blink", line 30, in <module>
> >    from blink import Blink
> >  File "/usr/local/lib/python2.7/dist-packages/blink/__init__.py", line
> > 13, in <module>
> >    import sip
> > ImportError: No module named sip]
> > 
> 
> You need to have python-sip installed, which should be a dependency of python-qt4. Did you use our repositories to install Blink?
> 
> > 
> > But Archlinux's error messages are the important here, because that's
> > what I use.
> > 
> > 
> > Thanks in advance
> > Mike
> > _______________________________________________
> > Blink mailing list
> > Blink at lists.ag-projects.com
> > http://lists.ag-projects.com/mailman/listinfo/blink
> 
> --
> Saúl Ibarra Corretgé
> AG Projects
> 
> 
> 



> _______________________________________________
> Blink mailing list
> Blink at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/blink




More information about the Blink mailing list