[Blink] ffmpeg dependency

Saúl Ibarra Corretgé saul at ag-projects.com
Tue Aug 9 14:26:30 CEST 2016


> On 09 Aug 2016, at 12:16, Mike Nagie <promike1987 at gmail.com> wrote:
> 
> Hello,
> 
> I'd like to ask you about the dependencies of the Sipsimple.
> I try to maintain the Arch PKGBUILD
> ( https://aur.archlinux.org/packages/python2-sipsimple/ )
> and ffmpeg was reported to cause problems.
> 
> Comments are visible on the page but here's the bottom line:
> 
> This happens when only ffmpeg (3.1.2) is installed.
> 
> ImportError: libvpx.so.3: cannot open shared object file: No such file
> or directory
> 
> 
> 
> And only with ffmpeg2.8:
> 
> aconfigure: error: *** Error: libavformat not detected ***
> 
> 
> 
> So which version of ffmpeg is suggested, or both ffmpeg and ffmpeg2.8
> are really needed at the same time?
> 

Hi,

We depend on ffmpeg >= 2.8 and also in libvpx, so you’ll need both installed. I’m not aware of problems when building against ffmpeg 2.8, that’s what we use on Debian Jessie, for example.

As a general rule, even if Arch doesn’t use it, I suggest checking our debian/control file, it contains the always up to date list of required dependencies.


Regards,

--
Saúl Ibarra Corretgé
AG Projects





-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 842 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.ag-projects.com/pipermail/blink/attachments/20160809/8d9ad20a/attachment.sig>


More information about the Blink mailing list