[Blink] Blink OTR module error

Mike Nagie promike1987 at gmail.com
Fri Apr 15 09:54:22 CEST 2016


Hello,

I'd have liked to try the new Blink, but something might be missing.

$ blink
Traceback (most recent call last):
  File "/usr/bin/blink", line 30, in <module>
    from blink import Blink
  File "/usr/lib/python2.7/site-packages/blink/__init__.py", line 27, in 
<module>
    from sipsimple.application import SIPApplication
  File "/usr/lib/python2.7/site-packages/sipsimple/application.py", line 
33, in <module>
    from sipsimple.session import SessionManager
  File "/usr/lib/python2.7/site-packages/sipsimple/session.py", line 37, 
in <module>
    from sipsimple.streams import MediaStreamRegistry, 
InvalidStreamError, UnknownStreamError
  File "/usr/lib/python2.7/site-packages/sipsimple/streams/__init__.py", 
line 118, in <module>
    from sipsimple.streams import msrp, rtp
  File 
"/usr/lib/python2.7/site-packages/sipsimple/streams/msrp/__init__.py", 
line 396, in <module>
    from sipsimple.streams.msrp import chat, filetransfer, screensharing
  File 
"/usr/lib/python2.7/site-packages/sipsimple/streams/msrp/chat.py", line 
25, in <module>
    from otr import OTRSession, OTRTransport, OTRState, SMPStatus
ImportError: No module named otr

My Arch is up-to-date, and if 'libotr' package is the culprit it seems 
up-to-date too : local/libotr 4.1.1-1


More information about the Blink mailing list