[SIP Beyond VoIP] Important: python-sipsimple_0.31.0 is incompatible with python-msrplib-0.15.0

ANIL KARADAĞ anil.karadag at gmail.com
Wed Jan 30 07:54:01 CET 2013


Hi Adrian,


thanks for your reply. I can upgrade it but I think sipsimple-0.31's
dependencies are not correct.
I installed the following packages;

- python-msrplib-0.15.0 (python-msrplib-0.15.0.tar.gz)
- python-sipsimple_0.31.0 (python-sipsimple-0.31.0.tar.gz)
- sylkserver_2.2.1


but the error is raised. I checked the last version of the
sipsimple/streams/msrp.py[1], the problematic class does not has
"*received_illegal_data"
*method. Please explain that why msrplib calls the undefined method?


[1]
http://sipsimpleclient.org/projects/sipsimpleclient/repository/revisions/5089/entry/sipsimple/streams/msrp.py



On Wed, Jan 30, 2013 at 1:12 AM, Adrian Georgescu <ag at ag-projects.com>wrote:

> Hello Anil,
>
> First of all I advise to upgrade to the latest version.
>
> http://sipsimpleclient.org/projects/sipsimpleclient/wiki/SipInstallation
>
> The dependencies of 0.31 were:
>
> Package: python-sipsimple Architecture: any Depends: ${python:Depends},
> ${shlibs:Depends}, ${misc:Depends}, python-application (>= 1.4.0),
> python-backports, python-dateutil, python-dnspython (>= 1.6),
> python-eventlib, python-gnutls, python-lxml, python-msrplib (>= 0.15.0),
> python-twisted-core (>= 8.1.0), python-xcaplib (>= 1.0.17)
>
> Adrian
>
>
> On Jan 29, 2013, at 5:03 PM, ANIL KARADAĞ wrote:
>
> Hi Adrian/ Saúl,
>
>
>
> I use python-msrplib-0.15.0 (python-msrplib-0.15.0.tar.gz) and
> python-sipsimple_0.31.0 (python-sipsimple-0.31.0.tar.gz) but get the
> following error when send invalid data, which does not start with "MSRP"
>
>
>
> Traceback (most recent call last):
> File
> "/usr/lib64/python2.6/site-packages/Twisted-12.2.0-py2.6-linux-x86_64.egg/twisted/internet/posixbase.py",
> line 626, in _doReadOrWrite
>     why = selectable.doRead()
> File
> "/usr/lib64/python2.6/site-packages/Twisted-12.2.0-py2.6-linux-x86_64.egg/twisted/internet/tcp.py",
> line 203, in doRead
>     return self._dataReceived(data)
> File
> "/usr/lib64/python2.6/site-packages/Twisted-12.2.0-py2.6-linux-x86_64.egg/twisted/internet/tcp.py",
> line 209, in _dataReceived
>     rval = self.protocol.dataReceived(data)
> File
> "/usr/lib64/python2.6/site-packages/Twisted-12.2.0-py2.6-linux-x86_64.egg/twisted/protocols/basic.py",
> line 564, in dataReceived
>     why = self.lineReceived(line)
> File "/usr/lib/python2.6/site-packages/msrplib/transport.py", line 55, in
> lineReceived
>     protocol.MSRPProtocol.lineReceived(self, line)
> File "/usr/lib/python2.6/site-packages/msrplib/protocol.py", line 502, in
> lineReceived
>    *self.msrp_transport.logger.received_illegal_data(line+self.delimiter,
> self.msrp_transport)*
> *AttributeError: 'NotificationProxyLogger' object has no attribute
> 'received_illegal_data'*
> *
> *
> *
> *
> I checked sipsimple/streams/msrp.py, the 'NotificationProxyLogger' class
> does not have the mentioned method.
> *
> *
> *Which msrplib release is compatible with the python-sipsimple_0.31.0?*
>
>
> thanks
>
> --
> Anıl KARADAĞ
> http://anilkaradag.info/blog
> _______________________________________________
> SIPBeyondVoIP mailing list
> SIPBeyondVoIP at lists.ag-projects.com
> http://lists.ag-projects.com/mailman/listinfo/sipbeyondvoip
>
>
>


-- 
Anıl KARADAĞ
http://anilkaradag.info/blog
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ag-projects.com/pipermail/sipbeyondvoip/attachments/20130130/2b33558a/attachment.html>


More information about the SIPBeyondVoIP mailing list