[SIP Beyond VoIP] Sylk-Server does not run on Ubuntu 11.04natty due to type error

Anil KARADAG akaradag at NETAS.com.tr
Fri Oct 5 15:45:04 CEST 2012


I agree with you. 

root at trhtlangley35:/home/ntsysadm/Documents/packages# echo $PYTHONPATH

root at trhtlangley35:/home/ntsysadm/Documents/packages#



-----Original Message-----
From: Saúl Ibarra Corretgé [mailto:saul at ag-projects.com] 
Sent: Friday, October 05, 2012 4:38 PM
To: Anil KARADAG
Cc: Adrian Georgescu; sipbeyondvoip at lists.ag-projects.com
Subject: Re: [SIP Beyond VoIP] Sylk-Server does not run on Ubuntu 11.04natty due to type error

Hi,

On Oct 5, 2012, at 3:31 PM, Anil KARADAG wrote:

> Hi Saúl,
> 
> 
> Yes, python-twisted has been installed.
> 
> root at trhtlangley35:/etc/sylkserver# aptitude search python-twisted
> c   python-twisted                                                         - Event-based framework for internet applications (transitional package)
> i   python-twisted-bin                                                     - Event-based framework for internet applications
> p   python-twisted-bin-dbg                                                 - Event-based framework for internet applications (debug extension)
> p   python-twisted-calendarserver                                          - Twisted components for Apple's Calendarserver
> c   python-twisted-conch                                                   - The Twisted SSH Implementation
> i   python-twisted-core                                                    - Event-based framework for internet applications
> p   python-twisted-lore                                                    - Documentation generator with HTML and LaTeX support
> p   python-twisted-mail                                                    - An SMTP, IMAP and POP protocol implementation
> i   python-twisted-names                                                   - A DNS protocol implementation with client and server
> p   python-twisted-news                                                    - An NNTP protocol implementation with client and server
> p   python-twisted-runner                                                  - Process management, including an inetd server
> p   python-twisted-runner-dbg                                              - Process management, including an inetd server (debug extension)
> p   python-twisted-snmp                                                    - SNMP implementation for the Twisted networking framework
> i   python-twisted-web                                                     - An HTTP protocol implementation together with clients and servers
> p   python-twisted-web2                                                    - An HTTP/1.1 Server Framework
> i   python-twisted-words                                                   - Chat and Instant Messaging
> 
> 
> 
> root at trhtlangley35:/etc/sylkserver# python
> Python 2.7.1+ (r271:86832, Sep 27 2012, 21:12:17)
> [GCC 4.5.2] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import twisted
>>>> from twisted.python import failure
> /usr/lib/python2.7/dist-packages/zope/__init__.py:3: UserWarning: Module twisted was already imported from /usr/local/lib/python2.7/dist-packages/Twisted-12.2.0-py2.7-linux-x86_64.egg/twisted/__init__.pyc, but /usr/local/lib/python2.7/dist-packages/wokkel-0.7.0-py2.7.egg is being added to sys.path
>  import pkg_resources
>>>> from gnutls.interfaces.twisted import X509Credentials
>>>> from sipsimple.account import Account, BonjourAccount, AccountManager
>>>> from sylk.server import SylkServer
>>>> import os
>>>> os.system("/usr/bin/sylk-server --no-fork");
> Starting SylkServer 2.1.0, config=/etc/sylkserver/config.ini
> fatal error: failed to create SylkServer: expected string or Unicode object, NoneType found
> Traceback (most recent call last):
>  File "/usr/bin/sylk-server", line 68, in main
>    from sylk.server import SylkServer
>  File "/usr/lib/python2.7/dist-packages/sylk/server.py", line 13, in <module>
>    from sipsimple.account import Account, BonjourAccount, AccountManager
>  File "/usr/local/lib/python2.7/dist-packages/sipsimple/account/__init__.py", line 22, in <module>
>    from gnutls.interfaces.twisted import X509Credentials
>  File "/usr/lib/python2.7/dist-packages/gnutls/interfaces/twisted/__init__.py", line 10, in <module>
>    from twisted.python import failure
>  File "/usr/lib/python2.7/dist-packages/application/log/extensions/twisted/twisted.py", line 14, in <module>
>    import twisted
> TypeError: expected string or Unicode object, NoneType found
> 256

You seem to have a mixture of libraries in /usr/lib/python2.7 and /usr/local/python2.7 You'll need to make sure the PYTHONPATH environment variable is properly set, as you seem to be importing modules from both places.


Regards,

--
Saúl Ibarra Corretgé
AG Projects





More information about the SIPBeyondVoIP mailing list